FailureResolution Class

FailureResolution Class

Defines a resolution for a failure.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFailureResolution
    Autodesk.Revit.DBDeleteElements
    Autodesk.Revit.DBDisableAnalyticalModelCB

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FailureResolution : IDisposable
Public Class FailureResolution
	Implements IDisposable
public ref class FailureResolution : IDisposable
type FailureResolution = 
    class
        interface IDisposable
    end

The FailureResolution type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FailureResolution
Top
Remarks
A failure could have several permitted resolutions. List of applicable resolution types for the specific failure is defined by the FailureDefinition, actual FailureResolutions are instantiated with the FailureMessage before it is posted. Multiple resolutions per failure are allowed, although Revit UI only uses default resolution.
See Also