FormatStatus Enumeration

FormatStatus Enumeration

An enumerated type indicating the formatting status of a range of characters in FormattedText

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum FormatStatus
Public Enumeration FormatStatus
public enum class FormatStatus
type FormatStatus
Members
Member nameValueDescription
All1 All of the characters in the range have the specified format.
Mixed2 The characters in the format have mixed formatting.
None0 None of the characters in the range has the specified format.
Remarks
The character formatting includes
  • Bold
  • Italic
  • Underline
  • SuperScript
  • Subscript
  • All Caps
See Also