PlanCircuitSet Class

PlanCircuitSet Class

A set that can contain any number of plan circuit objects.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBPlanCircuitSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PlanCircuitSet : APIObject, 
	IEnumerable
Public Class PlanCircuitSet
	Inherits APIObject
	Implements IEnumerable
public ref class PlanCircuitSet : public APIObject, 
	IEnumerable
type PlanCircuitSet = 
    class
        inherit APIObject
        interface IEnumerable
    end

The PlanCircuitSet type exposes the following members.

Constructors
 NameDescription
Public methodPlanCircuitSetInitializes a new instance of the PlanCircuitSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertySizeReturns the number of objects that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every item from the set, rendering it empty.
Public methodContainsTests for the existence of an item within the set.
Public methodEraseRemoves a specified object from the set.
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodInsertInsert the specified item into the set.
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Top
See Also