DocumentDifference Class

DocumentDifference Class

DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDocumentDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DocumentDifference : IDisposable
Public Class DocumentDifference
	Implements IDisposable
public ref class DocumentDifference : IDisposable
type DocumentDifference = 
    class
        interface IDisposable
    end

The DocumentDifference type exposes the following members.

Properties
 NameDescription
Public propertyAreDeletedElementIdsAvailable Whether or the deleted elements were retrieved.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DocumentDifference
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetCreatedElementIds Created element id collection.
Public methodGetDeletedElementIds Deleted element id collection. For non-worksharing models, this will always be an empty collection.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetModifiedElementIds Modified element id collection.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
For workshared models, DocumentDifference may contain all the added elements, modified elements and deleted elements. For non-workshared models, deleted elements are not tracked, so this object may only contain added elements and modified elements.
See Also