STLExportOptions.TargetUnit Property

STLExportOptionsTargetUnit Property

The unit type of geometry in the resultant STL file. Default value is ExportUnit::Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ExportUnit TargetUnit { get; set; }
Public Property TargetUnit As ExportUnit
	Get
	Set
public:
property ExportUnit TargetUnit {
	ExportUnit get ();
	void set (ExportUnit value);
}
member TargetUnit : ExportUnit with get, set

Property Value

ExportUnit
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also