ParameterMapIterator Class

ParameterMapIterator Class

An iterator to a map relating a parameter name (the key, a String) to a parameter.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBParameterMapIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public abstract class ParameterMapIterator : APIObject, 
	IEnumerator
Public MustInherit Class ParameterMapIterator
	Inherits APIObject
	Implements IEnumerator
public ref class ParameterMapIterator abstract : public APIObject, 
	IEnumerator
[<AbstractClassAttribute>]
type ParameterMapIterator = 
    class
        inherit APIObject
        interface IEnumerator
    end

The ParameterMapIterator type exposes the following members.

Constructors
 NameDescription
Public methodParameterMapIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the item that is the current focus of the iterator.
Public propertyKeyRetrieves the key that is the current focus of the iterator.
Top
Methods
 NameDescription
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the map.
Top
See Also