IntersectionResultArrayIterator Class

IntersectionResultArrayIterator Class

An iterator to a array.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBIntersectionResultArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public abstract class IntersectionResultArrayIterator : APIObject, 
	IEnumerator
Public MustInherit Class IntersectionResultArrayIterator
	Inherits APIObject
	Implements IEnumerator
public ref class IntersectionResultArrayIterator abstract : public APIObject, 
	IEnumerator
[<AbstractClassAttribute>]
type IntersectionResultArrayIterator = 
    class
        inherit APIObject
        interface IEnumerator
    end

The IntersectionResultArrayIterator type exposes the following members.

Constructors
 NameDescription
Public methodIntersectionResultArrayIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the item that is the current focus of the iterator.
Top
Methods
 NameDescription
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the array.
Top
See Also