Revit 2025.3 API
IExternal |
Implement this method to check whether the given ExternalResourceReference is formatted
correctly for this server.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
bool IsResourceWellFormed( ExternalResourceReference extRef )
Function IsResourceWellFormed ( extRef As ExternalResourceReference ) As Boolean
bool IsResourceWellFormed( ExternalResourceReference^ extRef )
abstract IsResourceWellFormed : extRef : ExternalResourceReference -> bool
Parameters
- extRef ExternalResourceReference
- The ExternalResourceReference to check.
Return Value
BooleanTrue if the ExternalResourceReference represents a well-formed resource. False otherwise.

Different servers will have different requirements.
A server which loads references from a website might require that the reference map contain a key called "URL" and a value that is a valid URL.
A server which loads references from a network drive might require a key called "Drive" with a value that represents a drive name, plus a key called "Path" with a value that corresponds to a path relative to the root of the drive.
This function should not check that the resource exists on the server. It should only check that the resource is formatted correctly.
See Also