Parameter.AsDouble Method

ParameterAsDouble Method

Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public double AsDouble()
Public Function AsDouble As Double
public:
double AsDouble()
member AsDouble : unit -> float 

Return Value

Double
The double value contained in the parameter.
Remarks
The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.
See Also