ReinforcementData Class

ReinforcementData Class

Abstract class for various reinforcement data
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureReinforcementData
    Autodesk.Revit.DB.StructureRebarReinforcementData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ReinforcementData : IDisposable
Public Class ReinforcementData
	Implements IDisposable
public ref class ReinforcementData : IDisposable
type ReinforcementData = 
    class
        interface IDisposable
    end

The ReinforcementData type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ReinforcementData
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also