Revit 2025.3 API
Point |
Define a ReferencePoint relative to a Face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The PointOnFace type exposes the following members.


Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetFaceReference | Get a copy of the face reference. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | SetFaceReference | Change the face reference. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

A ReferencePoint on a Face has its X and Y
basis vectors parallel to the Face, but is free to rotate
around its Z basis vector. It must lie on the face
(unlike PointOnPlane).
See Also