Revit 2025.3 API
Point |
Define a ReferencePoint relative to a Face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The PointOnFace type exposes the following members.


Name | Description | |
---|---|---|
![]() | GetFaceReference | Get a copy of the face reference. |
![]() | SetFaceReference | Change the face reference. |

A ReferencePoint on a Face has its X and Y
basis vectors parallel to the Face, but is free to rotate
around its Z basis vector. It must lie on the face
(unlike PointOnPlane).
See Also