Revit 2025.3 API
DocumentPath |
The fully qualified path of the document's disk file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public string PathName { get; }
Public ReadOnly Property PathName As String Get
public: property String^ PathName { String^ get (); }
member PathName : string with get
Property Value
String
This string is empty if the project has not been saved
or does not have a disk file associated with it yet.
Note that the pathname will be empty if a document is detached. See IsDetached.
See Also