RebarConstraint.GetSurfaceForConstraintToSurface Method

RebarConstraintGetSurfaceForConstraintToSurface Method

This method retrieves the surface for a constraint of 'To Surface' type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Surface GetSurfaceForConstraintToSurface()
Public Function GetSurfaceForConstraintToSurface As Surface
public:
Surface^ GetSurfaceForConstraintToSurface()
member GetSurfaceForConstraintToSurface : unit -> Surface 

Return Value

Surface
Returns the surface that the RebarConstraint of 'To Surface' type is using.
Exceptions
ExceptionCondition
InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToSurface'.
See Also