Revit 2025.3 API
Format |
Options for formatting numbers with units into strings.

SystemObject
Autodesk.Revit.DBFormatValueOptions
Autodesk.Revit.DBFormatValueOptions
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The FormatValueOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | FormatValueOptions | Creates a new FormatValueOptions object with default settings. |

Name | Description | |
---|---|---|
![]() | AppendUnitSymbol | Indicates if a unit symbol should be appended regardless of the settings in the FormatOptions. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FormatValueOptions |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also