CompoundStructureError Enumeration

CompoundStructureError Enumeration

When CompoundStructure::isValid() returns false, it uses these values to indicate precise nature of defect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum CompoundStructureError
Public Enumeration CompoundStructureError
public enum class CompoundStructureError
type CompoundStructureError
Members
Member nameValueDescription
BadShellOrder0 Layer Function Priorities ascend from the Core Boundary to the Finish Face.
BadShellsStructure5 The number of shell layers is larger than the total number of layers.
CoreTooThin1 Core contain a membrane layer or thickness of core is zero.
DeckCantBoundAbove12 There is no layer above Structural deck or it is too thin.
DeckCantBoundBelow13 There is no layer below Structural deck or it is too thin.
ExtensibleRegionsNotContiguousAlongBottom17 Extension Layers at the bottom of the wall must be adjacent.
ExtensibleRegionsNotContiguousAlongTop16 Extension Layers at the top of the wall must be adjacent.
InvalidMaterialId15 Element id used as material id does not correspond to an actual MaterialElem.
InvalidProfileId18 Element id used as profile id does not correspond to a valid deck profile.
MembraneTooThick3 Thickness of membrane layer is more than zero.
NonmembraneTooThin4 Thickness of non-membrane layer is too thin.
ThinOuterLayer6 Thickness of face layer is too thin.
VarThickLayerCantBeZero14 Variable thickness layer have zero thickness.
VerticalUnusedLayer7 A layer is not membrane layer and the Thickness of layer is zero.
VerticalWrongOrderCoreExterior9 Exterior core boundary have more than one face at any height.
VerticalWrongOrderCoreInterior10 Interior core boundary have more than one face at any height.
VerticalWrongOrderLayer8 Layers assigned to the same Row are not on the same side of the Core Boundary.
VerticalWrongOrderMembrane11 Membrane Layer have more than one face at any height.
Remarks
'LayerTooThin' enum value was removed in 2016
See Also