Hub.GetOrigin Method

HubGetOrigin Method

Retrieves position of a Hub if such position is a 3D point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ GetOrigin()
Public Function GetOrigin As XYZ
public:
XYZ^ GetOrigin()
member GetOrigin : unit -> XYZ 

Return Value

XYZ
The origin.
Exceptions
ExceptionCondition
InvalidOperationException Hub does not have an Origin.
See Also