BuiltInFailures.GenericMEPFailures Class

BuiltInFailuresGenericMEPFailures Class

Failures applicable to different mechanical, electrical and piping Elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresGenericMEPFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class GenericMEPFailures
Public NotInheritable Class GenericMEPFailures
public ref class GenericMEPFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GenericMEPFailures = class end

The BuiltInFailuresGenericMEPFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCapsWereAddedWarning X caps were added.
Public propertyStatic memberCapWasAddedWarning 1 cap was added.
Public propertyStatic memberFailedToPlaceCapWarning Failed to place cap on the open connector.
Public propertyStatic memberFlowConfigMismatch [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
Public propertyStatic memberFlowDirectionMismatch [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
Public propertyStatic memberInlineEndoflineMismatch [Element Name]: It is not possible to calculate the flow since there is inline equipment that is configured as end of line. Please check equipment in this system and make sure that the equipment connectors used inline have a global system classification and a calculated flow configuration. Global equipment connectors used inline should always be linked to each other.
Public propertyStatic memberMaxWidthAndHeightReached Maximum width and height reached during sizing
Public propertyStatic memberSegmentIsTooShort The segment is too short.
Public propertyStatic memberSizingFailedZeroFlow Sizing failed. Flow for section is 0.
Public propertyStatic memberSplitElementDeletionWarning The value specified for the Joint Gap exceeds the length of the split segment, so the segment will be deleted.
Public propertyStatic memberValidatePHSegmentConnWarning The placeholder curve will not be able to connect to the required fittings for placeholder convert
Public propertyStatic memberValidatePHSegmentLengthWarning The placeholder curve is not long enough to support the required fittings for placeholder convert
Top
See Also