Document.GetProjectId Method

DocumentGetProjectId Method

Gets ForgeDM project id where the model locates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public string GetProjectId()
Public Function GetProjectId As String
public:
String^ GetProjectId()
member GetProjectId : unit -> string 

Return Value

String
Exceptions
ExceptionCondition
RevitServerUnauthorizedException Thrown when cannot get data from ForgeDM for Revit cloud model.
Remarks
It is empty for non-cloud model; It is cached in Revit model opened session after getting it;
See Also