ViewFamily Enumeration

ViewFamily Enumeration

An enumerated type that corresponds to the type of a Revit view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ViewFamily
Public Enumeration ViewFamily
public enum class ViewFamily
type ViewFamily
Members
Member nameValueDescription
AreaPlan110 Area plan view.
CeilingPlan111 Ceiling plan view.
CostReport106 Cost report view (obsolete).
Detail113 Detail view.
Drafting108 Drafting view.
Elevation114 Elevation view.
FloorPlan109 Floor plan view.
GraphicalColumnSchedule119 Graphical column schedule.
ImageView104 Rendering view.
Invalid101 Invalid view type.
Legend117 Legend view.
LoadsReport115 HVAC load report.
PanelSchedule118 Panel schedule.
PressureLossReport116 Pressure loss report.
Schedule105 Schedule view.
Section112 Section view.
Sheet107 Sheet view.
StructuralPlan120 Structural plan view.
SystemsAnalysisReport121 Systems analysis report.
ThreeDimensional102 3D view.
Walkthrough103 Walkthrough view.
See Also