Element.Id Property

ElementId Property

A unique identifier for an Element in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId Id { get; }
Public ReadOnly Property Id As ElementId
	Get
public:
property ElementId^ Id {
	ElementId^ get ();
}
member Id : ElementId with get

Property Value

ElementId
Remarks
Returns an object containing the project-wide unique identifier for this Element. The identifier with this id is only unique for the project, it is not unique across separate Autodesk Revit projects.
See Also