RebarConstraint.GetDistanceToTargetCover Method

RebarConstraintGetDistanceToTargetCover Method

Returns the distance from the RebarConstrainedHandle to the target Host Cover Element surface. The RebarConstraintType of the RebarConstraint must be 'ToCover'.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public double GetDistanceToTargetCover()
Public Function GetDistanceToTargetCover As Double
public:
double GetDistanceToTargetCover()
member GetDistanceToTargetCover : unit -> float 

Return Value

Double
Exceptions
ExceptionCondition
InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToCover'.
See Also