KeyBasedTreeEntryErrorType Enumeration

KeyBasedTreeEntryErrorType Enumeration

An Enum indicating the type of error associated with a KeyBasedTreeEntry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum KeyBasedTreeEntryErrorType
Public Enumeration KeyBasedTreeEntryErrorType
public enum class KeyBasedTreeEntryErrorType
type KeyBasedTreeEntryErrorType
Members
Member nameValueDescription
BadClassificationCategoryId5 The classification category id is not Revit BuiltInCategory id.
BadClassificationLevel4 The classification level is not an integer in range between 1 and 5 inclusive.
CircularParentage2 A sub-node has been specified as a parent of one of its ancestors.
DuplicateEntry0 The same entry appears more than once in the KeyBasedTreeEntries object.
InvalidClassificationCode3 The classification code does not match the level and parent code.
MissingParent1 The parent specified for a entry does not exist in the KeyBasedTreeEntires object.
See Also