LinePatternSegment Class

LinePatternSegment Class

Represents a segment in a line pattern.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBLinePatternSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LinePatternSegment : IDisposable
Public Class LinePatternSegment
	Implements IDisposable
public ref class LinePatternSegment : IDisposable
type LinePatternSegment = 
    class
        interface IDisposable
    end

The LinePatternSegment type exposes the following members.

Constructors
 NameDescription
Public methodLinePatternSegment Creates a line pattern segment.
Public methodLinePatternSegment(LinePatternSegmentType, Double) Creates a line pattern segment with given type and length.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLength Gets and sets the length of the segment.
Public propertyType Gets and sets the type of the segment.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the LinePatternSegment
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also