Revit 2025.3 API
Built |
Failures related to divided path operations.

SystemObject
Autodesk.Revit.DBBuiltInFailuresDividedPathFailures
Autodesk.Revit.DBBuiltInFailuresDividedPathFailures
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The BuiltInFailuresDividedPathFailures type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | DividedPathCannotApplyDivideSettings | Default Divide settings cannot be applied to Divided Path. |
![]() ![]() | DividedPathCannotBeMirroredWithoutItsCurves | Divided path cannot be mirrored without its curves. |
![]() ![]() | DividedPathCannotCreateFromGeometry | Highlighted geometry contains a path or edge that could not be divided. |
![]() ![]() | DividedPathDistanceTooSmall | Distance is too small. |
![]() ![]() | DividedPathIndentsOverlap | Beginning indent and end indent overlap. |
![]() ![]() | DividedPathIntersectionPolycurveParamsStepFailed | Intersection failed. |
![]() ![]() | DividedPathInvalidNumberOfPoints | End indent is too large. |
![]() ![]() | DividedPathLayoutStepFailed | Layout algorithm failed. |
![]() ![]() | DividedPathUpdateMergedPointKeysStepFailed | Merging failed. |
See Also