RebarSpliceTypeUtils Class

RebarSpliceTypeUtils Class

Utility class for dealing with Rebar Splice Type operations. To find all Rebar Splice Types in the document can be done using FilteredElementCollector of category BuiltInCategory.OST_RebarSpliceType.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureRebarSpliceTypeUtils

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class RebarSpliceTypeUtils
Public NotInheritable Class RebarSpliceTypeUtils
public ref class RebarSpliceTypeUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RebarSpliceTypeUtils = class end

The RebarSpliceTypeUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberCreateRebarSpliceType Creates a Rebar Splice Type element.
Public methodStatic memberGetAllRebarSpliceTypes Gets all the Rebar Splice Types elements from the document.
Public methodStatic memberGetLapLengthMultiplier Gets the lap length multiplier value.
Public methodStatic memberGetShiftOption Identifies the way bars are shifted in the splice relation.
Public methodStatic memberGetStaggerLengthMultiplier Gets the stagger multiplier value.
Public methodStatic memberSetLapLengthMultiplier Sets the lap length multiplier value.
Public methodStatic memberSetShiftOption Sets the way bars are shifted in the splice relation.
Public methodStatic memberSetStaggerLengthMultiplier Sets the lap length multiplier value.
Top
See Also