Revit 2025.3 API
ParameterSet(Element |
Sets the parameter to a new element id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool Set( ElementId value )
Public Function Set ( value As ElementId ) As Boolean
public: bool Set( ElementId^ value )
member Set : value : ElementId -> bool
Parameters
- value ElementId
- The new element id to which the parameter is to be set.
Return Value
BooleanThe Set method will return True if the parameter was successfully set to the new value, otherwise false.

Exception | Condition |
---|---|
InvalidOperationException | The parameter is read-only. |

You should only use this method if the StorageType property reports the type of the
parameter as an ElementId.
See Also