ScheduleFilterType Enumeration

ScheduleFilterType Enumeration

Type of schedule filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ScheduleFilterType
Public Enumeration ScheduleFilterType
public enum class ScheduleFilterType
type ScheduleFilterType
Members
Member nameValueDescription
BeginsWith10 For a string field, the field value begins with the specified string.
Contains8 For a string field, the field value contains the specified string.
EndsWith12 For a string field, the field value ends with specified string.
Equal2 The field value is equal to the specified value.
GreaterThan4 The field value is greater than the specified value.
GreaterThanOrEqual5 The field value is greater than or equal to the specified value.
HasNoValue17 The element does not have a value for the specified parameter. No value is specified.
HasParameter1 The element has the parameter specified by the field. Used with shared parameters. No value is specified for this filter type.
HasValue16 The element has a value for the specified parameter. No value is specified.
Invalid0 An invalid filter. Do not use.
IsAssociatedWithGlobalParameter14 The field is associated with a specified global parameter of a compatible type
IsNotAssociatedWithGlobalParameter15 The field is not associated with a specified global parameter of a compatible type
LessThan6 Less The field value is less than to the specified value.
LessThanOrEqual7 The field value is less than or equal to the specified value.
NotBeginsWith11 For a string field, the field value does not begin with the specified string.
NotContains9 For a string field, the field value does not contain the specified string.
NotEndsWith13 For a string field, the field value does not end with the specified string.
NotEqual3 The field value is not equal to the specified value.
See Also