Revit 2025.3 API
Duct |
Erase the existing MEPSize with this nominal diameter. The duct shape determines the location of the size in the size table.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void RemoveSize( DuctShape shape, double nominalDiameter )
Public Sub RemoveSize ( shape As DuctShape, nominalDiameter As Double )
public: void RemoveSize( DuctShape shape, double nominalDiameter )
member RemoveSize : shape : DuctShape * nominalDiameter : float -> unit
Parameters
- shape DuctShape
- The shape of duct.
- nominalDiameter Double
- Nominal diameter.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InvalidOperationException | Throws if the function is called during iterating the size set. |

Does nothing if there is no existing MEPSize with this nominal diameter.
See Also