FabricSheetLayoutPattern Enumeration

FabricSheetLayoutPattern Enumeration

The pattern for how the wires in Fabric Sheet are laid out.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum FabricSheetLayoutPattern
Public Enumeration FabricSheetLayoutPattern
public enum class FabricSheetLayoutPattern
type FabricSheetLayoutPattern
Members
Member nameValueDescription
ActualSpacing0 The spacing between the rebars is fixed and specified by input.
FixedNumber1 The spacing between the rebars is adjustable, but the number of bars is constant based on input.
MaximumSpacing2 The maximum distance between the rebars is specified by input, and the number of rebars changes based on the length of rebar set.
NumberWithSpacing3 Both the spacing between the rebars and the number of rebars are constant based on input.
QuantitativeSpacing4 Multiple groups of wires with a specific spacing and diameter
See Also