CurveArray.Item Property

CurveArrayItem Property

Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public virtual Curve this[
	int index
] { get; set; }
Public Overridable Property Item ( 
	index As Integer
) As Curve
	Get
	Set
public:
virtual property Curve^ Item[int index] {
	Curve^ get (int index);
	void set (int index, Curve^ value);
}
abstract Item : Curve with get, set
override Item : Curve with get, set

Parameters

index  Int32
The index of the curve to be set or retrieved.

Return Value

Curve
Returns the curve at the specified index.
See Also