BuiltInFailures.SketchFailures.NonMonotoneRoof Property

BuiltInFailuresSketchFailuresNonMonotoneRoof Property

All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static FailureDefinitionId NonMonotoneRoof { get; }
Public Shared ReadOnly Property NonMonotoneRoof As FailureDefinitionId
	Get
public:
static property FailureDefinitionId^ NonMonotoneRoof {
	FailureDefinitionId^ get ();
}
static member NonMonotoneRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also