View.RestoreCalloutParent Method

ViewRestoreCalloutParent Method

Restores callout parent ID to the original view ID if that view is still available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void RestoreCalloutParent()
Public Sub RestoreCalloutParent
public:
void RestoreCalloutParent()
member RestoreCalloutParent : unit -> unit 
Exceptions
ExceptionCondition
InvalidOperationException This view is not a callout.
Remarks
Nothing is done if the callout already has parent or if the original callout parent is deleted or is not parallel to the callout view.
See Also