Curve.IsClosed Property

CurveIsClosed Property

Describes whether the curve is closed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
	Get
public:
property bool IsClosed {
	bool get ();
}
member IsClosed : bool with get

Property Value

Boolean
Remarks
A curve is "closed" if it is bounded and its start and end points coincide (to within Revit's 3D tolerance), or if it is unbounded and periodic.
See Also