Revit 2025.3 API
RailingGet |
Gets the ids of the base levels of the stairs upon which this railing is placed.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ISet<ElementId> GetMultistoryStairsPlacementLevels()
Public Function GetMultistoryStairsPlacementLevels As ISet(Of ElementId)
public: ISet<ElementId^>^ GetMultistoryStairsPlacementLevels()
member GetMultistoryStairsPlacementLevels : unit -> ISet<ElementId>
Return Value
ISetElementIdThe ids of levels the railing is placed on. The returned set consists of a subset of the base level ids of the corresponding stairs in the MultistoryStairs.

Exception | Condition |
---|---|
InvalidOperationException | The railing is not hosted by stairs in MultistoryStairs. |

The method is valid only for railings hosted by stairs in MultistoryStairs.
See Also