Revit 2025.3 API
IExternal |
Implement this method to return a description of the server.
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
string GetDescription()
Function GetDescription As String
String^ GetDescription()
abstract GetDescription : unit -> string
Return Value
StringDescription of the server.

The purpose of this string is to describe the external server in more details than just a short name alone could do. The intended use is to show the string to the end user in UI when UI is appropriate for the corresponding external service.
Beside the requirement for it to be a non-empty string, there are no other general restrictions imposed by the External Services Framework. However, the external service may have some specific rules in place for its servers.
See Also