CurtainGridSet Class

CurtainGridSet Class

A set that can contain any type of object.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCurtainGridSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class CurtainGridSet : APIObject, 
	IEnumerable
Public Class CurtainGridSet
	Inherits APIObject
	Implements IEnumerable
public ref class CurtainGridSet : public APIObject, 
	IEnumerable
type CurtainGridSet = 
    class
        inherit APIObject
        interface IEnumerable
    end

The CurtainGridSet type exposes the following members.

Constructors
 NameDescription
Public methodCurtainGridSetInitializes a new instance of the CurtainGridSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertySizeReturns the number of objects that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every item from the set, rendering it empty.
Public methodContains 
Public methodErase 
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodInsert 
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Top
See Also