WorksetKindFilter(WorksetKind, Boolean) Constructor

WorksetKindFilter(WorksetKind, Boolean) Constructor

Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public WorksetKindFilter(
	WorksetKind worksetKind,
	bool inverted
)
Public Sub New ( 
	worksetKind As WorksetKind,
	inverted As Boolean
)
public:
WorksetKindFilter(
	WorksetKind worksetKind, 
	bool inverted
)
new : 
        worksetKind : WorksetKind * 
        inverted : bool -> WorksetKindFilter

Parameters

worksetKind  WorksetKind
The WorksetKind to match.
inverted  Boolean
True if the filter should match all worksets which are not of the given WorksetKind.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also