DoubleArray Class

DoubleArray Class

An array that contains doubles.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDoubleArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DoubleArray : APIObject, 
	IEnumerable
Public Class DoubleArray
	Inherits APIObject
	Implements IEnumerable
public ref class DoubleArray : public APIObject, 
	IEnumerable
type DoubleArray = 
    class
        inherit APIObject
        interface IEnumerable
    end

The DoubleArray type exposes the following members.

Constructors
 NameDescription
Public methodDoubleArrayInitializes a new instance of the DoubleArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyItemGets or sets a double at a specified index within the array.
Public propertySizeReturns the number of doubles that are in the array.
Top
Methods
 NameDescription
Public methodAppend 
Public methodClearRemoves every double from the array, rendering it empty.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsert 
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also