Revit 2025.3 API
Failure |
Retrieves the type of resolution to be used to resolve the failure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public FailureResolutionType GetCurrentResolutionType()
Public Function GetCurrentResolutionType As FailureResolutionType
public: FailureResolutionType GetCurrentResolutionType()
member GetCurrentResolutionType : unit -> FailureResolutionType
Return Value
FailureResolutionTypeThe type of failure resolution to be used to resolve the failure.

Exception | Condition |
---|---|
InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions. |

If the current resolution type was never set for the failure, FailureResolutionType::Default is returned.
See Also