FailureDefinition Class

FailureDefinition Class

Defines persistent information about a failure.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFailureDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FailureDefinition : IDisposable
Public Class FailureDefinition
	Implements IDisposable
public ref class FailureDefinition : IDisposable
type FailureDefinition = 
    class
        interface IDisposable
    end

The FailureDefinition type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySeverity The severity of the failure.
Top
Methods
 NameDescription
Public methodAddResolutionType Adds a type of possible resolution for the failure.
Public methodStatic memberCreateFailureDefinition Creates an instance of a FailureDefinition.
Public methodDisposeReleases all resources used by the FailureDefinition
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetApplicableResolutionTypes Retrieves a list of resolution types applicable to the failure.
Public methodGetDefaultResolutionType Retrieves the default resolution type for the failure.
Public methodGetDescriptionText Retrieves the description text of the failure.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetResolutionCaption Retrieves the caption for a specific resolution type.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodHasResolutions Checks if the FailureDefinition has at least one resolution.
Public methodIsResolutionApplicable Checks if the given resolution type is applicable to the failure.
Public methodSetDefaultResolutionType Sets the default resolution type for the failure.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Each failure that can be potentially posted in Revit must be based on a FailureDefinition object that contains some persistent information about failure such as identity, severity, basic description text, types of resolution and default resolution. Each FailureMessage, which contains variable part of the information for a specific failure when it occurs, is created with a reference to a registered FailureDefinition. In order to be able to post a failure, one must define and register it via FailureDefinition object during Revit Application startup.
See Also