ImageTypeSource Enumeration

ImageTypeSource Enumeration

The source of the data used to generate the image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ImageTypeSource
Public Enumeration ImageTypeSource
public enum class ImageTypeSource
type ImageTypeSource
Members
Member nameValueDescription
Import1 The image data was imported into the Revit document.
Internal2 The image data was created internally. These are rendering images or views saved in the project as images.
Link0 The image data is from an externally linked image file.
See Also