BuiltInFailures.PointFailures Class

BuiltInFailuresPointFailures Class

Failures about Point Element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresPointFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class PointFailures
Public NotInheritable Class PointFailures
public ref class PointFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PointFailures = class end

The BuiltInFailuresPointFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCannotMakePointHostedByIntersection Cannot make point hosted by intersection.
Public propertyStatic memberCantChangeParamFlip Can't flip Element.
Public propertyStatic memberCantChangeParamMirror Can't mirror Element.
Public propertyStatic memberCantChangeParamRotate Can't rotate Element.
Public propertyStatic memberEdgeHostedPointToBeUnhosted A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
Public propertyStatic memberHostMeasurementError Invalid host curve measurement type or value or justification
Public propertyStatic memberHostParameterRangeError Hosted Parameter must be between 0 and 1
Public propertyStatic memberRegenFailure Regeneration Failure.
Top
See Also