FilterNumericGreater Class

FilterNumericGreater Class

Tests whether numeric values from the document are greater than a certain value
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterNumericRuleEvaluator
    Autodesk.Revit.DBFilterNumericGreater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FilterNumericGreater : FilterNumericRuleEvaluator
Public Class FilterNumericGreater
	Inherits FilterNumericRuleEvaluator
public ref class FilterNumericGreater : public FilterNumericRuleEvaluator
type FilterNumericGreater = 
    class
        inherit FilterNumericRuleEvaluator
    end

The FilterNumericGreater type exposes the following members.

Constructors
 NameDescription
Public methodFilterNumericGreater Constructs an instance of FilterNumericGreater.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterNumericRuleEvaluator)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FilterNumericRuleEvaluator)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluate(Int32, Int32)Obsolete.
Derived classes should override this method to implement the desired test.
(Inherited from FilterNumericRuleEvaluator)
Public methodEvaluate(Int64, Int64) Derived classes should override this method to implement the desired test.
(Inherited from FilterNumericRuleEvaluator)
Public methodEvaluate(Double, Double, Double) Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.
(Inherited from FilterNumericRuleEvaluator)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also