Revit 2025.3 API
Fill |
Gets and sets the shift of the fill grid.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public double Shift { get; set; }
Public Property Shift As Double Get Set
public: property double Shift { double get (); void set (double value); }
member Shift : float with get, set
Property Value
DoubleThe shift of the fill grid.

Shift moves the pattern of dashes and spaces along the length of each new parallel line.
Shift is ignored if the line is solid.
See Also