ImageTypeStatus Enumeration

ImageTypeStatus Enumeration

Indicates the current state of the contents of the ImageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ImageTypeStatus
Public Enumeration ImageTypeStatus
public enum class ImageTypeStatus
type ImageTypeStatus
Members
Member nameValueDescription
FailedToLoad2

The linked image could not be loaded from file.

Some possible reasons are:
  • The file could not be found
  • The file could be corrupt or not contain image data
  • In case of PDF files, the file might be encrypted or not have the requested page
Generated5 The internally created image is available.
Imported4 The image was imported and is available.
Loaded1 The linked image was successfully loaded.
Unknown0 The linked image has not yet been loaded. No image is available. This status is only returned before the document is fully opened.
Unloaded3 The linked images was unloaded by the user. No image is available.
See Also