Revit 2025.3 API
External |
Data that describes a remote folder to be shown in the file browser dialog

SystemObject
Autodesk.Revit.DBExternalResourceSubFolder
Autodesk.Revit.DBExternalResourceSubFolder
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ExternalResourceSubFolder type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExternalResourceSubFolder | Constructs a new ExternalResourceSubFolder with default values for folder name and icon path. |
![]() | ExternalResourceSubFolder(String, String) | Constructs a new ExternalResourceSubFolder with custom values for folder name and icon path. |

Name | Description | |
---|---|---|
![]() | FolderName | Folder displayed name. |
![]() | IconPath | The path of the resource icon. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ExternalResourceSubFolder |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also