CurveByPointsArrayIterator Class

CurveByPointsArrayIterator Class

An iterator to a CurveByPoints array.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCurveByPointsArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public abstract class CurveByPointsArrayIterator : APIObject, 
	IEnumerator
Public MustInherit Class CurveByPointsArrayIterator
	Inherits APIObject
	Implements IEnumerator
public ref class CurveByPointsArrayIterator abstract : public APIObject, 
	IEnumerator
[<AbstractClassAttribute>]
type CurveByPointsArrayIterator = 
    class
        inherit APIObject
        interface IEnumerator
    end

The CurveByPointsArrayIterator type exposes the following members.

Constructors
 NameDescription
Public methodCurveByPointsArrayIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the item that is the current focus of the iterator.
Top
Methods
 NameDescription
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the array.
Top
See Also