RebarShapeDefinition Class

RebarShapeDefinition Class

A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureRebarShapeDefinition
    Autodesk.Revit.DB.StructureRebarShapeDefinitionByArc
    Autodesk.Revit.DB.StructureRebarShapeDefinitionBySegments

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RebarShapeDefinition : IDisposable
Public Class RebarShapeDefinition
	Implements IDisposable
public ref class RebarShapeDefinition : IDisposable
type RebarShapeDefinition = 
    class
        interface IDisposable
    end

The RebarShapeDefinition type exposes the following members.

Properties
 NameDescription
Public propertyComplete Report whether the shape definition is fully constrained.
Public propertyIsPlanar Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodAddFormulaParameter Add a formula-driven parameter to the shape definition.
Public methodAddParameter Add a parameter to the shape definition.
Public methodCheckDefaultParameterValues Check that the shape can be solved with the default parameter values.
Public methodDisposeReleases all resources used by the RebarShapeDefinition
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetParameterDefaultValue Return the parameter's default value as stored in the definition.
Public methodGetParameterFormula Return the parameter's formula, if one is associated with it.
Public methodGetParameters Return the Ids of the shared parameters in the Definition.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodHasParameter Whether the definition stores the parameter.
Public methodRemoveParameter Remove the parameter from the definition.
Public methodSetParameterDefaultValue Change the parameter's value as stored in the definition.
Public methodSetParameterFormula Associate a formula with the parameter.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A RebarShapeDefinition stores a set of Rebar Shape parameters. Each parameter may be associated with:
  • One or more RebarShapeConstraints; or
  • A formula; or
  • Neither of the above.
Each shape instance (Rebar object) will have its own values for these parameters. The RebarShapeDefinition also stores a default value for each parameter, which is ignored if the parameter is associated with a formula.
See Also