Revit 2025.3 API
Units Constructor |
Creates a new Units object with default settings for Metric or Imperial units.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Units( UnitSystem unitSystem )
Public Sub New ( unitSystem As UnitSystem )
public: Units( UnitSystem unitSystem )
new : unitSystem : UnitSystem -> Units
Parameters
- unitSystem UnitSystem
- Indicates whether the Units object should be initialized with default settings for Metric or Imperial units.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
See Also