EntryAndSchemeConsistency Enumeration

EntryAndSchemeConsistency Enumeration

Enumeration used to specify why an entry is inconsistent with a scheme or another entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum EntryAndSchemeConsistency
Public Enumeration EntryAndSchemeConsistency
public enum class EntryAndSchemeConsistency
type EntryAndSchemeConsistency
Members
Member nameValueDescription
Consistent0 The scheme entry can be applied to the scheme.
InconsistentStorageType1 The type of value stored in the entry is different from the type of the scheme parameter.
InvalidFillPatternId4 The fill pattern id is not valid.
ValueDuplicated3 There already exists another entry with the same value.
ValueOutOfRange2 The value stored in the entry is out of the scheme parameter range.
See Also